ユーザー登録で「300円クーポン」プレゼント!まずは無料登録から!
募集をシェアしてメンターを探そう
シェア
エンジニア Heroku herokuへのデブロイ アプリ開発 プログラミング

オリジナルアプリ作成途中のherokuデプロイにて、git push heroku master ができないエラーが発生しております

3月9日
予算
3,000円 〜 3,000円
提案数
1人が提案中

オリジナルアプリ作成途中のherokuデプロイにて、git push heroku master ができないエラーが発生しており、
remote: -----> Building on the Heroku-20 stack
remote: ! Warning: Multiple default buildpacks reported the ability to handle this app. The first buildpack in the list below will be used.
remote: Detected buildpacks: Ruby,Node.js
remote: See https://devcenter.heroku.com/articles/buildpacks#buildpack-detect-order
remote: -----> Ruby app detected
remote: -----> Installing bundler 2.2.11
remote: -----> Removing BUNDLED WITH version in the Gemfile.lock
remote: -----> Compiling Ruby/Rails
remote: -----> Using Ruby version: ruby-3.0.0
remote: -----> Installing dependencies using bundler 2.2.11
remote: Running: BUNDLE_WITHOUT='development:test' BUNDLE_PATH=vendor/bundle BUNDLE_BIN=vendor/bundle/bin BUNDLE_DEPLOYMENT=1 bundle install -j4
remote: Your bundle only supports platforms ["x86_64-darwin-20"] but your local platform
remote: is x86_64-linux. Add the current platform to the lockfile with `bundle lock
remote: --add-platform x86_64-linux` and try again.
remote: Bundler Output: Your bundle only supports platforms ["x86_64-darwin-20"] but your local platform
remote: is x86_64-linux. Add the current platform to the lockfile with `bundle lock
remote: --add-platform x86_64-linux` and try again.
remote:
remote: !
remote: ! Failed to install gems via Bundler.
remote: !
remote: ! Push rejected, failed to compile Ruby app.
remote:
remote: ! Push failed
remote: !
remote: ! ## Warning - The same version of this code has already been built: fdf697de5a71e348e8b3439a2013449cee86eaf8
remote: !
remote: ! We have detected that you have triggered a build from source code with version fdf697de5a71e348e8b3439a2013449cee86eaf8
remote: ! at least twice. One common cause of this behavior is attempting to deploy code from a different branch.
このようなエラーが発生しております、qiitaや個人のブログサイトに書かれていることを一通り試してみたのですが、以前エラーが発生しております。
早急に解決したいのでできれば、今日、明日中に対応してくれる方を探しております

メンティーに提案してみましょう
募集をシェアしてメンターを探そう
シェア