学習方法

メンター情報

料金

対応時間帯

返信スピード

学習方法

メンター情報

料金

対応時間帯

返信スピード

h☆

25日前

募集をシェアしてメンターを探そう
シェア

※ この募集は締め切られました。

プログラミング RubyonRails

rspec nokogiri エラー

2022年2月13日
単発
予算
1,000円 〜
提案数
1人が提案中
応募期限
終了

Macm1を使用しています。
スクールの課題で
Ruby on railsの開発をdockerを使い行っています。ci設定しています。

rspecテスト最初通っていた状態で、
rubocopにエラーがでており、
そちらを対応し解消したのち、
再度ciを通したところ、
今度はrspecがエラーになってしまいました。(ローカルでもエラーになります)

下記のようにエラーが出たので、
nokogiriをまず、
インストールしないと行けないと解釈しました。
https://qiita.com/yuki82511988/items/e73224f551cb80dab2f1
こちらの記事を参考に対応したのですが
上手く行かず、
エラーの解釈が間違っているのか
なかなか上手くいかず
教えていただきたいです。

ERROR: It looks like you're trying to use Nokogiri as a precompiled native gem on a system with glibc < 2.17:

/lib/aarch64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /potepanec/vendor/bundle/ruby/2.7.0/gems/nokogiri-1.13.1-aarch64-linux/lib/nokogiri/2.7/nokogiri.so) - /potepanec/vendor/bundle/ruby/2.7.0/gems/nokogiri-1.13.1-aarch64-linux/lib/nokogiri/2.7/nokogiri.so

If that's the case, then please install Nokogiri via the `ruby` platform gem:
gem install nokogiri --platform=ruby
or:
bundle config set force_ruby_platform true

Please visit https://nokogiri.org/tutorials/installing_nokogiri.html for more help.


ERROR: It looks like you're trying to use Nokogiri as a precompiled native gem on a system with glibc < 2.17:

/lib/aarch64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /potepanec/vendor/bundle/ruby/2.7.0/gems/nokogiri-1.13.1-aarch64-linux/lib/nokogiri/2.7/nokogiri.so) - /potepanec/vendor/bundle/ruby/2.7.0/gems/nokogiri-1.13.1-aarch64-linux/lib/nokogiri/2.7/nokogiri.so

If that's the case, then please install Nokogiri via the `ruby` platform gem:
gem install nokogiri --platform=ruby
or:
bundle config set force_ruby_platform true

Please visit https://nokogiri.org/tutorials/installing_nokogiri.html for more help.


ERROR: It looks like you're trying to use Nokogiri as a precompiled native gem on a system with glibc < 2.17:

/lib/aarch64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /potepanec/vendor/bundle/ruby/2.7.0/gems/nokogiri-1.13.1-aarch64-linux/lib/nokogiri/2.7/nokogiri.so) - /potepanec/vendor/bundle/ruby/2.7.0/gems/nokogiri-1.13.1-aarch64-linux/lib/nokogiri/2.7/nokogiri.so

If that's the case, then please install Nokogiri via the `ruby` platform gem:
gem install nokogiri --platform=ruby
or:
bundle config set force_ruby_platform true

Please visit https://nokogiri.org/tutorials/installing_nokogiri.html for more help.


An error occurred while loading ./spec/features/products_spec.rb. - Did you mean?
rspec ./spec/rquests/potepan/products_spec.rb

Failure/Error: require File.expand_path('../config/environment', __dir__)

(一部抜粋しております)

h☆

25日前

募集をシェアしてメンターを探そう
シェア