Q&Aサイトで、書籍の通りにコードを書いても動かないという質問がありました。

Laravelのバージョンアップで、使えなくなる書き方や、書籍が利用しているライブラリが動かなくなるといったことがあります。

書籍でLaravelを学習する際は、書籍が対応したバージョンに合わせてインストールして学習しましょう。

#5.5
composer create-project "laravel/laravel=5.5.*" myproject
#5.6
composer create-project "laravel/laravel=5.6.*" myproject
#5.7
composer create-project "laravel/laravel=5.7.*" myproject
#5.8
composer create-project "laravel/laravel=5.8.*" myproject

参考として、Laravel関連の書籍の対応バージョンに合ったインストール方法を記載しておきます。

PHPフレームワーク Laravel入門

#5.5対応
composer create-project "laravel/laravel=5.5.*" myproject

PHPフレームワークLaravel Webアプリケーション開発

#5.5対応
composer create-project "laravel/laravel=5.5.*" myproject